home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / app-admin / eselect-1.0 / eselect-1.0.ebuild < prev    next >
Text File  |  2006-04-12  |  1KB  |  51 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/app-admin/eselect/eselect-1.0.ebuild,v 1.10 2006/03/14 03:28:34 vapier Exp $
  4.  
  5. DESCRIPTION="Modular -config replacement utility"
  6. HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
  7. SRC_URI="mirror://gentoo/${P}.tar.bz2"
  8.  
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
  12. IUSE="doc bash-completion"
  13.  
  14. DEPEND="sys-apps/sed
  15.     doc? ( dev-python/docutils )"
  16. RDEPEND="sys-apps/sed"
  17.  
  18. src_compile() {
  19.     econf || die "econf failed"
  20.     emake || die "emake failed"
  21.  
  22.     if use doc ; then
  23.         make html || die "failed to build html"
  24.     fi
  25. }
  26.  
  27. src_install() {
  28.     make DESTDIR="${D}" install || die "make install failed"
  29.     dodoc AUTHORS NEWS README TODO doc/*.txt
  30.     use doc && dohtml *.html doc/*
  31.  
  32.     # we don't use bash-completion.eclass since eselect
  33.     # is listed in RDEPEND.
  34.     if use bash-completion ; then
  35.         insinto /usr/share/bash-completion
  36.         newins misc/${PN}.bashcomp ${PN} || die
  37.     fi
  38. }
  39.  
  40. pkg_postinst() {
  41.     if use bash-completion ; then
  42.         echo
  43.         einfo
  44.         einfo "To enable command-line completion for eselect, run:"
  45.         einfo
  46.         einfo "  eselect bashcomp enable eselect"
  47.         einfo
  48.         echo
  49.     fi
  50. }
  51.